Images

For talking about LunarNET, the site. Requests, suggestions, complaints, praises, etc. are for this board.
User avatar
Ozone
Dragonmaster
Posts: 3039
Joined: Wed Dec 25, 2002 2:06 pm
Location: .above.the.weeping.world.
Contact:

Images

Postby Ozone » Thu May 05, 2005 2:24 am

I'm not seeing any of the images.....
"'There are no atheists in foxholes' isn't an argument against atheism, it's an argument against foxholes." - James Morrow
"I'll hit your head with the thunder clap, you're seeing Horus"

User avatar
Erroneous
Legendary Hero
Posts: 1190
Joined: Mon Jan 13, 2003 3:08 am
Location: Washington, USA
Contact:

Postby Erroneous » Thu May 05, 2005 2:49 am

Always happens to every website out there when a webmaster turns on hotlink prevention. If I recall it has to do with ISP, those with a decent ISP won't have that problem if a webmaster decides to use hotlink. However I think there is a fix but I forgot where and how. http://www.w3.org may have a solution

User avatar
GhaleonOne
Ghost From The Past
Posts: 9052
Joined: Wed Dec 25, 2002 4:59 am
Location: Not of this world...
Contact:

Postby GhaleonOne » Thu May 05, 2005 2:56 am

Wait, you mean there a lot of people that can't see the site because of it?
-G1

User avatar
Erroneous
Legendary Hero
Posts: 1190
Joined: Mon Jan 13, 2003 3:08 am
Location: Washington, USA
Contact:

Postby Erroneous » Thu May 05, 2005 3:04 am

GhaleonOne wrote:Wait, you mean there a lot of people that can't see the site because of it?


Basically

After I set up my hotlink prevention, a few people I knew in Indianapolis couldn't view the images on the site and would get red X's. People lost intrest in the site so I didn't even bother finding a fix.

User avatar
GhaleonOne
Ghost From The Past
Posts: 9052
Joined: Wed Dec 25, 2002 4:59 am
Location: Not of this world...
Contact:

Postby GhaleonOne » Thu May 05, 2005 3:18 am

Hm, I may have to rethink this hotlinking problem.
-G1

User avatar
Kizyr
Keeper of Knowledge (probationary)
Posts: 8011
Joined: Wed Dec 25, 2002 7:36 am
Location: Marius Zone
Contact:

Postby Kizyr » Thu May 05, 2005 5:08 am

GhaleonOne wrote:Hm, I may have to rethink this hotlinking problem.


We can kill the hotlinkers.

I mean kill their internet connectivity. KF

User avatar
Jenner
Dragonmaster
Posts: 2285
Joined: Thu Dec 26, 2002 1:24 am
Location: Happily ever after
Contact:

Postby Jenner » Wed May 11, 2005 4:10 am

Kizyr wrote:We can kill the hotlinkers.

I mean kill their internet connectivity. KF



Then, we can defile their corpses. :P
Image
The Infamous Jenner!
Maker of Lists.
RIP Coley...
Image
still adore you Kiz.

User avatar
Sonic#
Pao Tribe Chieftain
Posts: 4522
Joined: Thu Dec 26, 2002 3:27 am
Location: Here, there, everywhere
Contact:

Postby Sonic# » Wed May 11, 2005 2:55 pm

Ah, that's punny.

De-file, harhar. ^_~
Sonic#

"Than seyde Merlion, "Whethir lyke ye bettir the swerde othir the scawberde?" "I lyke bettir the swerde," seyde Arthure. "Ye ar the more unwyse, for the scawberde ys worth ten of the swerde; for whyles ye have the scawberde uppon you, ye shall lose no blood, be ye never so sore wounded. Therefore kepe well the scawberde allweyes with you." --- Le Morte Darthur, Sir Thomas Malory

"Just as you touch the energy of every life form you meet, so, too, will will their energy strengthen you. Fail to live up to your potential, and you will never win. " --- The Old Man at the End of Time

User avatar
Dragonship Destiny
Iluk Crackpot
Posts: 31
Joined: Tue Aug 02, 2005 4:46 am
Location: In the midst of Lunar...

Postby Dragonship Destiny » Tue Aug 02, 2005 4:52 am

I am able to see the images. Compliments to the creator of this site.

User avatar
artzi
Red Dragon Priest
Posts: 143
Joined: Mon Oct 25, 2004 4:05 pm
Location: Helsinki, Finland Level: 666
Contact:

Postby artzi » Tue Aug 02, 2005 2:26 pm

no problems here.8)
[url=http://www.rpgamer.com]
Image[/url]

User avatar
GhaleonOne
Ghost From The Past
Posts: 9052
Joined: Wed Dec 25, 2002 4:59 am
Location: Not of this world...
Contact:

Postby GhaleonOne » Wed Aug 03, 2005 4:43 am

That's because the hotlink disabler isn't turned on at the moment. I turned it off due to complaints from people not being able to see the Lunar DS official site.
-G1

User avatar
Erroneous
Legendary Hero
Posts: 1190
Joined: Mon Jan 13, 2003 3:08 am
Location: Washington, USA
Contact:

Postby Erroneous » Fri Aug 05, 2005 9:31 am

GhaleonOne wrote:Hm, I may have to rethink this hotlinking problem.


Hmmm, follow up on possible fixes to your hotlinking troubles. The source of the problem is because of viewers behind firewalls and proxy's. Do not use Cpanel's version of hotlinking, instead try below.

Contact one of these people who state they can not view the images on the site. Then try the 4 possible solutions by creating a file called .htaccess and copy and paste an option into it and upload it to your domain root folder and ask the user to refresh and respond if they can see anything. If they can't then try another code until they can view the images on the site but can't view images when its being posting on another site. Different servers act differently and one of these will help find the source of that type of problem you're encountering, one will allow to prevent hotlinking while allowing the images to be viewable for our firewalled and proxy users.

Option A

Code: Select all

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunarthreads.com(/)?.*$     [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunar-net.com(/)?.*$     [NC]
RewriteRule .*\.(gif|jpg|jpeg|bmp)$ - [F,NC]


Option B

Code: Select all

Options +FollowSymlinks
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunarthreads.com(/)?.*$     [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunar-net.com(/)?.*$     [NC]
RewriteRule .*\.(gif|jpg|jpeg|bmp)$ - [F,NC]


Option C

Code: Select all

Options +FollowSymlinks
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunarthreads.com(/)?.*$     [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunar-net.com(/)?.*$     [NC]
RewriteRule .*\.(gif|jpg|jpeg|bmp)$ - [F,NC]


Option D

Code: Select all

RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunarthreads.com(/)?.*$     [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?lunar-net.com(/)?.*$     [NC]
RewriteRule .*\.(gif|jpg|jpeg|bmp)$ - [F,NC]

User avatar
Suetan
Lann Fisherman
Posts: 20
Joined: Tue May 30, 2006 5:51 pm
Contact:

Postby Suetan » Wed Jun 07, 2006 2:51 am

Hot link prevention stops people from linking to images that are on Lunar-net from a different website. If you're not able to see them while on this site then there's most likely a problem in linking between the pages/images, or there's permission conflicts.

You can fix this by going into your FTP client, and changing the CHMOD properties to 777. This should fix the problem. If it doesn't, you can email me and I'll look for more fixes.

User avatar
Erroneous
Legendary Hero
Posts: 1190
Joined: Mon Jan 13, 2003 3:08 am
Location: Washington, USA
Contact:

Postby Erroneous » Wed Jun 07, 2006 4:15 am

Suetan wrote:Hot link prevention stops people from linking to images that are on Lunar-net from a different website. If you're not able to see them while on this site then there's most likely a problem in linking between the pages/images, or there's permission conflicts.

You can fix this by going into your FTP client, and changing the CHMOD properties to 777. This should fix the problem. If it doesn't, you can email me and I'll look for more fixes.


Several ISP's in east-central USA have conflicts with hotlink scripts making it so that the image doesn't display reguardless of BBS. Espically known to happen on Surpass hosted websites.

User avatar
Suetan
Lann Fisherman
Posts: 20
Joined: Tue May 30, 2006 5:51 pm
Contact:

Postby Suetan » Wed Jun 07, 2006 5:07 am

That's simple to fix though. Go through the phpBB ACP, and enable the

Code: Select all

<img src="URL OF IMAGE">
tag

User avatar
Erroneous
Legendary Hero
Posts: 1190
Joined: Mon Jan 13, 2003 3:08 am
Location: Washington, USA
Contact:

Postby Erroneous » Wed Jun 07, 2006 5:31 am

Suetan wrote:That's simple to fix though. Go through the phpBB ACP, and enable the

Code: Select all

<img src="URL OF IMAGE">
tag


The question of this thread is "not seeing any images" wasn't referring to posted images but the images of the whole board itself. So doing that is pointless now isn't it? :wink:

User avatar
Suetan
Lann Fisherman
Posts: 20
Joined: Tue May 30, 2006 5:51 pm
Contact:

Postby Suetan » Fri Jun 09, 2006 5:23 pm

Then I misunderstood. My bad.


Return to “LunarNET”

Who is online

Users browsing this forum: No registered users and 1 guest